GPS POI Home POI FilesPOI ToolsPOI MapsGPS ForumSupport
  GPS Data Team
Your local business listing specialists

Home > Forums > Garmin > Nuvi firmware recovering - system software missing

Post new GPS POI data or GPS devices related topic in Garmin forum   Reply to topic Nuvi firmware recovering - system software missing Goto page


GPS: Garmin Nuvi 660

Post Nuvi firmware recovering - system software missing     
Reply with quote

Hello All,

I recently downloaded the Nuvi 660 firmware upgrade from the Garmin site to upgrade to v2.70. I did this as I read some other comments that the Garmin webupdater application has (in some cases) caused corruption.

I ran the firmware update as per the instructions from the Garmin website and two .bin files copied to the unit but the third file (I can't recall the extension) failed to copy with a file in use error. I could not work out a way to recover from this as the upgrade failed (not fully complete) and the only option was to reset the unit via the power button.

When the unit came back up again the following error came up on the screen:

"system software missing"

The Nuvi would not boot!

I contacted the local Garmin support rep and I was given the following sequence to recover from this condition:

1. Power off the unit.

2. HOLD down the power button and you will see "Pre Boot Mode" appear on the lower part of the display. KEEP HOLDING the power button down and the display will flicker, do this until the pre boot mode message disappears. This seems to take a long time (60 seconds at least).

3. Once the pre boot mode message disappears release the power button and your device will perform some activities to recover from the above problem.

Apparently this sequence will only work with the above error. I hope this assists other if they encounter this problem.

I still don't know why the firmware upgrade process failed BUT after performing the above sequence I found that the firmware upgrade had actually worked (strange).


View user's profile



Post Re Nuvi 660 firmware recovering - system software missing     
Reply with quote

Had the "system software missing" problem after attempting to upgrade software to v2.7 using the web updater.

Tried the fix posted by Nick - it works! - many thanks Nick.

Strangely when it came back up the v2.7 upgrade had worked for me too.



Post Re: Re Nuvi 660 firmware recovering - system software missin     
Reply with quote

Great, that solved all my problems. Thanks.

Happy holidays



Post system sotware missing     
Reply with quote

Fix worked for me on my nuvi 310 too....saved my xmas...many thanks



Post Garmin software missing     
Reply with quote

Worked for me 2! I actually broght my 310 back to the store 2 months ago and got a replacement after this happened before.



Post fix works for nuvi310d     
Reply with quote

hi nick, thanks from me as well for your accurate and useful post - was having kittens thinking i'd d**yed up my brand new garmin nuvi 310, but your instructions have saved the day.

DON'T USE WEBUPDATE to update the device is all i can say... go to the direct software update link:

- Download: Nuvi 660 software update version 4.70 (4.86 MB) as of December 11, 2008

Here as a guest


Reply with quote

The fix from Nick works on the Nuvi310 too Smile

Thanks Nick saved me a lot of heartache





Post works on nuvi 660 (north american version)     
Reply with quote

Thank you, thank you for sharing the info on holding power button down. I just updated my Nuvi 660 from v.3.5 to v3.6 software and got the error message. Yes, it took at least 60sec for pre boot mode to disappear but once it did, unit was back to normal with v3.6 OS. Thanks again Nick!



Post 310     
Reply with quote

i have 310 . same problem.

tried this thing. worked but kept loading up and rebooting
so i plugged it in to usb and reloaded the software then it works



Post nuvi 660     
Reply with quote

thank u, u guys helped out



Post Garmin 670 update to 4.30     
Reply with quote

Thanks You Nick!!!
Your procedure worked great,had the "System software missing" after a Webupdate_241. I was on WiFi late at night with very good speed,it all took only about 5 minutes. When I tried to do it again,I got the message that the 670 was already updated,tried to update again,got the message"The update file is corrupted".
But your procedure worked,took a good minute for the flicker and then the Pre-Boot message to disappear,then it started loading some Bluetooth update and then came back to the normal screen.
Thanks again,

guest 2


Post system software missing     
Reply with quote

Smile Your tip on holding the power button and waiting for the pre-boot sequence saved the day on my nuvi 350 when a software update to V6.0 failed and gave me the ill-fated "system software missing" error. When finished, the update had actually completed to V6.0



Post Nuvi 350     
Reply with quote

Thanks Nick.

For my Nuvi 350....your solution worked fine...


GPS: Nuvi660

Reply with quote

Mine suddently decided not to boot up - thanks for the advice Nick - it works.
View user's profile

Lisa M


Post Nuvi 250W "System Software Missing"     
Reply with quote

Holding the power button does not work for the Nuvi 250W. It seems to have committed suicide via the Garmin's software updater.

Display posts from previous:   
Post new GPS POI data or GPS devices related topic in Garmin forum Reply to topic Nuvi firmware recovering - system software missing
Home > GPS Forum > Garmin > Discussion

Goto page
Page 1 of 2

Jump to:  


Permalink: Nuvi firmware recovering - system software missing | Garmin forum